小型企业网络配置dhcp中继配置

优质老薛主机推荐:15%终身付款折扣:xwseo15 25%首次付款折扣 : xwseo115 点击下图进入购买

小型企业网络配置dhcp中继配置,要求:

某企业将dhcp服务器部署在核心交换机上,dhcp服务器和企业内的终端不在同一个网络,企业希望使用该服务器为终端动态分配ip地址。

主要知识点:dhcp中继用于在dhcp服务器和客户端之间转发dhcp报文,当dhcp服务器和客户端不在同一个网络时,需要配置dhcp中继,对于dhcp客户端来说,dhcp中继就是dhcp服务器,对于dhcp服务器来说,dhcp中继就是dhcp客户端。

小型企业网络配置dhcp中继配置

sw1配置如下:

<SW1>dis cu
#
sysname SW1
#
vlan batch 10
#
interface Ethernet0/0/1
port link-type access
port default vlan 10
#
interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094

sw2配置如下:

<SW2>dis cu
#
sysname SW2
#
vlan batch 10 20
#
dhcp enable
#
interface Vlanif10
ip address 192.168.10.254 255.255.255.0
dhcp select relay
dhcp relay server-ip 192.168.20.2
#
interface Vlanif20
ip address 192.168.20.1 255.255.255.0
#
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
port link-type access
port default vlan 20

coresw配置如下:

<coresw>dis cu
#
sysname coresw
#
undo info-center enable
#
vlan batch 20
#
dhcp enable
#
ip pool v10
gateway-list 192.168.10.254
network 192.168.10.0 mask 255.255.255.0
lease day 8 hour 0 minute 0
dns-list 114.114.114.114
#
interface Vlanif20
ip address 192.168.20.2 255.255.255.0
dhcp select global
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 20
#
ip route-static 192.168.10.0 255.255.255.0 192.168.20.1

实验现象:

经过测试我们发现通过dhcp中继电脑pc2可以获取到ip地址,也可以ping通192.168.20.2,实验完成。

 

赞 (0)
分享到:更多 ()